Separated E2Sim lib from E2SM-specific code
[sim/e2-interface.git] / e2sim / src / SCTP / CMakeLists.txt
similarity index 61%
rename from e2sim/src/X2AP/x2ap_asn_codec.hpp
rename to e2sim/src/SCTP/CMakeLists.txt
index a07f441..b069924 100644 (file)
@@ -1,7 +1,6 @@
-/*****************************************************************************
+#/*****************************************************************************
 #                                                                            *
-# Copyright 2019 AT&T Intellectual Property                                  *
-# Copyright 2019 Nokia                                                       *
+# Copyright 2020 AT&T Intellectual Property                                  *
 #                                                                            *
 # Licensed under the Apache License, Version 2.0 (the "License");            *
 # you may not use this file except in compliance with the License.           *
 # See the License for the specific language governing permissions and        *
 # limitations under the License.                                             *
 #                                                                            *
-******************************************************************************/
-#ifndef X2AP_ASN_CODEC_HPP
-#define X2AP_ASN_CODEC_HPP
+#******************************************************************************/
 
-#include "e2sim_defs.h"
-#include "asn_x2ap.hpp"
 
-#define X2AP_ERROR_MESSAGE_BUFFER       1024
-#define X2AP_PDU_PRINT_BUFFER           4096
+# For clarity: this generates object, not a lib as the CM command implies.
+#
+add_library( sctp_objects OBJECT e2sim_sctp.cpp e2sim_sctp.c)
 
-void x2ap_encode_pdu(x2ap_pdu_t* pdu, unsigned char* buf, int buf_size, int &encoded_size);
+target_include_directories (sctp_objects PUBLIC
+  $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/include>
+  $<INSTALL_INTERFACE:include>
+  PRIVATE src)
 
-void x2ap_decode_pdu(x2ap_pdu_t* pdu, unsigned char* buf, int &encoded_size);
 
-void x2ap_print_pdu(x2ap_pdu_t* pdu);
-
-#endif
+if( DEV_PKG )
+  install( FILES
+    e2sim_sctp.hpp
+    e2sim_sctp.h
+    DESTINATION ${install_inc}
+    )
+endif()
+# ---------------------------------------------------------------------------