Separated E2Sim lib from E2SM-specific code
[sim/e2-interface.git] / e2sim / src / SCTP / CMakeLists.txt
diff --git a/e2sim/src/SCTP/CMakeLists.txt b/e2sim/src/SCTP/CMakeLists.txt
new file mode 100644 (file)
index 0000000..b069924
--- /dev/null
@@ -0,0 +1,37 @@
+#/*****************************************************************************
+#                                                                            *
+# Copyright 2020 AT&T Intellectual Property                                  *
+#                                                                            *
+# Licensed under the Apache License, Version 2.0 (the "License");            *
+# you may not use this file except in compliance with the License.           *
+# You may obtain a copy of the License at                                    *
+#                                                                            *
+#      http://www.apache.org/licenses/LICENSE-2.0                            *
+#                                                                            *
+# Unless required by applicable law or agreed to in writing, software        *
+# distributed under the License is distributed on an "AS IS" BASIS,          *
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.   *
+# See the License for the specific language governing permissions and        *
+# limitations under the License.                                             *
+#                                                                            *
+#******************************************************************************/
+
+
+# For clarity: this generates object, not a lib as the CM command implies.
+#
+add_library( sctp_objects OBJECT e2sim_sctp.cpp e2sim_sctp.c)
+
+target_include_directories (sctp_objects PUBLIC
+  $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/include>
+  $<INSTALL_INTERFACE:include>
+  PRIVATE src)
+
+
+if( DEV_PKG )
+  install( FILES
+    e2sim_sctp.hpp
+    e2sim_sctp.h
+    DESTINATION ${install_inc}
+    )
+endif()
+# ---------------------------------------------------------------------------