python-glanceclient: add missing bash_completion file
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-glanceclient_git.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "Client library for Glance built on the OpenStack Images API."
17 HOMEPAGE = "https://opendev.org/openstack/python-glanceclient"
18 SECTION = "devel/python"
19 LICENSE = "Apache-2.0"
20 LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
21
22 SRCREV = "44a4dbd6ce2642daeaca9f45ac99e2d1b39e805a"
23 SRCNAME = "python-glanceclient"
24 BRANCH = "stable/train"
25 PROTOCOL = "https"
26 PV = "2.16.0+git${SRCPV}"
27 S = "${WORKDIR}/git"
28
29 SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
30         
31 inherit setuptools monitor rmargparse
32
33 DEPENDS += " \
34         python-pip \
35         python-pbr-native\
36         "
37
38 # Satisfy setup.py 'setup_requires'
39 DEPENDS += " \
40         python-pbr-native \
41         "
42
43 RDEPENDS_${PN} += " \
44         bash \
45         python-pbr \
46         python-prettytable \
47         python-keystoneauth1 \
48         python-warlock \
49         python-six \
50         python-oslo.utils \
51         python-oslo.i18n \
52         python-wrapt \
53         python-pyopenssl \
54         "
55
56
57 do_install_append() {
58         install -d -m 755 ${D}/${sysconfdir}/bash_completion.d
59         install -p -D -m 664 tools/glance.bash_completion ${D}/${sysconfdir}/bash_completion.d/glance
60
61 }
62
63 FILES_${PN} += " \
64         ${sysconfdir}/bash_completion.d/ \
65         "