python-cherrypy: add recipe for version 3.2.2
[pti/rtp.git] / meta-stx / recipes-core / packagegroups / packagegroup-stx.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "StarlingX stx packages"
17
18 PR = "r0"
19
20 #
21 # packages which content depend on MACHINE_FEATURES need to be MACHINE_ARCH
22 #
23
24 PACKAGE_ARCH = "${MACHINE_ARCH}"
25 inherit packagegroup
26
27 PROVIDES = "${PACKAGES}"
28 PACKAGES = " \
29         packagegroup-stx-upstream \
30         packagegroup-stx-puppet \
31         packagegroup-stx-fault \
32         packagegroup-stx-metal \
33         packagegroup-stx-nfv \
34         packagegroup-stx-monitoring \
35         packagegroup-stx-ha \
36         packagegroup-stx-config \
37         packagegroup-stx-config-files \
38         packagegroup-stx-distributedcloud \
39         packagegroup-stx-update \
40         packagegroup-stx-integ \
41         packagegroup-stx-utilities \
42         packagegroup-stx-armada-app \
43         "
44
45 RDEPENDS_packagegroup-stx-puppet = "\
46         stx-puppet \
47         puppet-dcdbsync \
48         puppet-dcmanager \
49         puppet-dcorch \
50         puppet-fm \
51         puppet-mtce \
52         puppet-nfv \
53         puppet-patching \
54         puppet-smapi \
55         puppet-sshd \
56         puppet-sysinv \
57         puppet-manifests \
58         "
59
60 RDEPENDS_packagegroup-stx-config = " \
61         config-gate-worker \
62         config-gate \
63         controllerconfig \
64         cgts-client \
65         sysinv-agent \
66         sysinv \
67         workerconfig-subfunction \
68         tsconfig \
69         "
70
71 RDEPENDS_packagegroup-stx-config-files  = " \
72         audit-config \
73         centos-release-config \
74         dhclient-config \
75         dnsmasq-config \
76         docker-config \
77         initscripts-config \
78         filesystem-scripts \
79         haproxy-config \
80         ioscheduler-config \
81         iptables-config \
82         iscsi-initiator-utils-config \
83         lighttpd-config \
84         logrotate-config \
85         memcached-custom \
86         mlx4-config \
87         net-snmp-config \
88         nfs-utils-config \
89         ntp-config \
90         openldap-config \
91         openssh-config \
92         openvswitch-config \
93         pam-config \
94         rabbitmq-server-config \
95         rsync-config \
96         setup-config \
97         shadow-utils-config \
98         sudo-config \
99         syslog-ng-config \
100         systemd-config \
101         util-linux-config \
102         "
103
104 RDEPENDS_packagegroup-stx-fault = " \
105         fm-api \
106         fm-common \
107         fm-doc \
108         fm-mgr \
109         fm-rest-api \
110         python-fmclient \
111         snmp-audittrail \
112         snmp-ext \
113         "
114
115 RDEPENDS_packagegroup-stx-ha = " \
116         sm-common-libs \
117         libsm-common \
118         sm \
119         sm-db \
120         sm-api \
121         sm-client \
122         sm-tools \
123         sm-eru \
124         stx-ocf-scripts \
125         "
126
127 RDEPENDS_packagegroup-stx-metal = " \
128         inventory \
129         mtce \
130         mtce-pmon \
131         mtce-hwmon \
132         mtce-hostw \
133         mtce-lmon \
134         mtce-compute \
135         mtce-control \
136         mtce-storage \
137         python-inventoryclient \
138         pxe-network-installer \
139         platform-kickstarts \
140         "
141
142 RDEPENDS_packagegroup-stx-monitoring = " \
143         collectd-extensions \
144         influxdb-extensions \
145         monitor-tools \
146         vm-topology \
147         "
148
149 RDEPENDS_packagegroup-stx-distributedcloud = " \
150         distributedcloud-dcmanager \
151         distributedcloud-dcorch \
152         distributedcloud-dcdbsync \
153         distributedcloud-ocf \
154         "
155
156 RDEPENDS_packagegroup-stx-nfv = " \
157         nfv-common \
158         nfv-plugins \
159         nfv-tools \
160         nfv-vim \
161         nfv-client \
162         "
163
164 RDEPENDS_packagegroup-stx-upstream = " \
165         barbican \
166         python-neutronclient \
167         python-aodhclient \
168         python-barbican \
169         python-barbicanclient \
170         python-cinderclient \
171         python-glanceclient \
172         python-gnocchiclient \
173         python-django-horizon \
174         python-heatclient \
175         python-ironicclient \
176         python-keystoneauth1 \
177         python-keystoneclient \
178         python-magnumclient \
179         python-muranoclient \
180         python-novaclient \
181         python-openstackclient \
182         python-openstacksdk \
183         python-pankoclient \
184         openstack-ras \
185         "
186
187 RDEPENDS_packagegroup-stx-update = " \
188         cgcs-patch \
189         cgcs-patch-agent \
190         cgcs-patch-controller \
191         enable-dev-patch \
192         patch-alarm \
193         "
194
195 RDEPENDS_packagegroup-stx-integ = " \
196         dpkg \
197         dtc \
198         ibsh \
199         python-redfishtool \
200         puppet-boolean \
201         puppetlabs-create-resources \
202         puppet-dnsmasq \
203         puppet-drbd \
204         puppet-filemapper \
205         puppet-ldap \
206         puppetlabs-lvm \
207         puppet-network \
208         puppet-nslcd \
209         puppetlabs-postgresql \
210         puppet-puppi \
211         mariadb \
212         drbd-utils \
213         docker-distribution \
214         docker-forward-journald \
215         etcd \
216         kubernetes \
217         ldapscripts \
218         python-3parclient \
219         python-cherrypy \
220         python-lefthandclient \
221         python-setuptools \
222         python-ryu \
223         spectre-meltdown-checker \
224         kvm-timer-advance \
225         ceph \
226         lldpd \
227         lvm2 \
228         tzdata \
229         "
230
231 RDEPENDS_packagegroup-stx-utilities = " \
232         build-info \
233         python-cephclient \
234         ceph-manager \
235         stx-ssl \
236         collector \
237         collect-engtools \
238         logmgmt \
239         namespace-utils \
240         nfscheck \
241         stx-extensions \
242         worker-utils \
243         update-motd \
244         platform-util \
245         pci-irq-affinity \
246         "
247
248 RDEPENDS_packagegroup-stx-armada-app = "\
249         monitor-helm \
250         monitor-helm-elastic \
251         openstack-helm \
252         openstack-helm-infra \
253         stx-monitor-helm \
254         stx-openstack-helm \
255         stx-platform-helm \
256         "