Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-support / libverto / libverto_0.2.5.bb
1
2 SUMMARY = "Event loop abstraction for Libraries"
3 DESCRIPTION = "Libverto exists to isolate libraries from the particular event loop \
4 chosen by an application. Libverto provides an asynchronous \
5 programming interface independent of any particular event loop and \
6 allows applications to attach this interface to whatever event loop \
7 they select."
8 HOMEPAGE = "http://fedorahosted.net/libverto"
9
10 LICENSE = "MIT"
11 LIC_FILES_CHKSUM = "file://COPYING;md5=bc8917ab981cfa6161dc29319a4038d9"
12
13
14 DEPENDS += "libevent libtevent"
15
16 # fedorahosted tarball cannot be fetched completely, so switch to use other source
17 # SRC_URI = "http://fedorahosted.org/releases/l/i/${PN}/${PN}-${PV}.tar.gz"
18 SRC_URI = "https://github.com/latchset/libverto/releases/download/0.2.5/${PN}-${PV}.tar.gz \
19           "
20 SRC_URI[md5sum] = "144fb8f00759ef8ad71c472333847f03"
21
22 inherit autotools pkgconfig
23
24 PACKAGECONFIG ??= "libevent tevent"
25 PACKAGECONFIG[glib] = "--with-glib,--without-glib,glib-2.0"
26 PACKAGECONFIG[libev] = "--with-libev,--without-libev,libev"
27 PACKAGECONFIG[libevent] = "--with-libevent,--without-libevent,libevent"
28 PACKAGECONFIG[tevent] = "--with-tevent,--without-tevent,libtevent"
29
30 PACKAGES =+ "${PN}-libevent ${PN}-tevent"
31
32 FILES_${PN}-libevent = "${libdir}/libverto-libevent${SOLIBS}"
33 FILES_${PN}-tevent = "${libdir}/libverto-tevent${SOLIBS}"
34
35 RPROVIDES_${PN}-libevent += "${PN}-module-base"
36 RPROVIDES_${PN}-tevent += "${PN}-module-base"
37