Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-support / drbd / drbd-utils_8.4.3.bb
1
2 SUMMARY = "Distributed block device driver for Linux"
3
4 DESCRIPTION = " DRBD, developed by LINBIT, is a software that allows RAID 1 functionality over \
5         TCP/IP and RDMA for GNU/Linux. DRBD is a block device which is designed to build high \
6         availability clusters and software defined storage by providing a virtual shared device \
7         which keeps disks in nodes synchronised using TCP/IP or RDMA. This simulates RAID 1 but \
8         avoids the use of uncommon hardware (shared SCSI buses or Fibre Channel)."
9 HOMEPAGE = "http://www.drbd.org/"
10 SECTION = "admin"
11 LICENSE = "GPLv2+"
12 LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
13
14 # SRCREV = "89a294209144b68adb3ee85a73221f964d3ee515"
15 SRCREV = "136c0e42691aed4a4607c79969de87cb8410285c"
16 PROTOCOL = "https"
17 BRANCH = "master"
18 S = "${WORKDIR}/git"
19 PV = "8.4.3rc1"
20
21 SRC_URI = "git://github.com/LINBIT/drbd-8.4.git;name="git";protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
22
23
24 # https://www.linbit.com/downloads/drbd/8.4/archive/
25
26 inherit autotools
27
28 DEPENDS += " \
29         linux-libc-headers \
30         glibc \
31         "
32 # UPSTREAM_CHECK_URI = "https://github.com/LINBIT/drbd-utils/releases"
33
34 inherit autotools-brokensep
35
36 RDEPENDS_${PN} += "bash perl-module-getopt-long perl-module-exporter perl-module-constant perl-module-overloading perl-module-exporter-heavy"
37
38 do_install_append() {
39         rm -rf ${D}/var/lock
40 }