Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-support / dnsmasq / dnsmasq_2.76.bb
1 SUMMARY = "Lightweight, easy to configure DNS forwarder and DHCP server"
2 DESCRIPTION = "\
3 Dnsmasq is lightweight, easy to configure DNS forwarder and DHCP server. \
4 It is designed to provide DNS and, optionally, DHCP, to a small network. \
5 It can serve the names of local machines which are not in the global \
6 DNS. The DHCP server integrates with the DNS server and allows machines \
7 with DHCP-allocated addresses to appear in the DNS with names configured \
8 either in each host or in a central configuration file. Dnsmasq supports \
9 static and dynamic DHCP leases and BOOTP for network booting of diskless \
10 machines. \
11 "
12 HOMEPAGE = "http://www.thekelleys.org.uk/dnsmasq"
13 SECTION = "net"
14
15 inherit stx-metadata
16
17 STX_REPO = "config-files"
18 STX_SUBPATH = "dnsmasq-config"
19
20 # GPLv3 was added in version 2.41 as license option
21 LICENSE = "GPLv2 | GPLv3"
22 LIC_FILES_CHKSUM = "\
23     file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
24     file://COPYING-v3;md5=d32239bcb673463ab874e80d47fae504 \
25 "
26
27 SRC_URI = " \
28     http://www.thekelleys.org.uk/${BPN}/${BP}.tar.gz \
29     file://init \
30     file://dnsmasq-resolvconf.service \
31     file://lua.patch \
32     \
33     file://stx/dnsmasq-2.76-dns-sleep-resume.patch \
34     file://stx/dnsmasq-2.76-fix-dhcp-option-arrangements.patch \
35     file://stx/dnsmasq-2.76-pftables.patch \
36     file://stx/dnsmasq-2.76-fix-crash-dns-resume.patch \
37     file://stx/dnsmasq-2.76-warning-fixes.patch \
38     file://stx/dnsmasq-2.76-label-warning.patch \
39     file://stx/dnsmasq-2.76-label-man.patch \
40     file://stx/dnsmasq-2.76-coverity.patch \
41     file://stx/dnsmasq-2.76-dhcp-script-log.patch \
42     file://stx/dnsmasq-2.76-file_offset32.patch \
43     file://stx/dnsmasq-2.76-CVE-2017-14491.patch \
44     file://stx/dnsmasq-2.76-CVE-2017-14492.patch \
45     file://stx/dnsmasq-2.76-CVE-2017-14493.patch \
46     file://stx/dnsmasq-2.76-CVE-2017-14494.patch \
47     file://stx/dnsmasq-2.76-CVE-2017-14496.patch \
48     file://stx/dnsmasq-2.76-CVE-2017-14495.patch \
49     file://stx/dnsmasq-2.76-gita3303e196.patch \
50     file://stx/dnsmasq-2.76-underflow.patch \
51     file://stx/dnsmasq-2.76-misc-cleanups.patch \
52     file://stx/dnsmasq-2.76-CVE-2017-14491-2.patch \
53     file://stx/dnsmasq-2.76-inotify.patch \
54     file://stx/dnsmasq-update-ipv6-leases-from-config.patch \
55     file://stx/close-tftp-sockets-immediately.patch \
56     file://stx/dnsmasq.service \
57 "
58 SRC_URI[md5sum] = "6610f8233ca89b15a1bb47c788ffb84f"
59 SRC_URI[sha256sum] = "777c4762d2fee3738a0380401f2d087b47faa41db2317c60660d69ad10a76c32"
60
61 inherit pkgconfig update-rc.d systemd
62
63 INITSCRIPT_NAME = "dnsmasq"
64 INITSCRIPT_PARAMS = "defaults"
65
66 PACKAGECONFIG ?= "dbus idn"
67 PACKAGECONFIG[dbus] = ",,dbus"
68 PACKAGECONFIG[idn] = ",,libidn"
69 PACKAGECONFIG[conntrack] = ",,libnetfilter-conntrack"
70 PACKAGECONFIG[lua] = ",,lua"
71 PACKAGECONFIG[resolvconf] = ",,,resolvconf"
72
73 EXTRA_OEMAKE = "\
74     'COPTS=${@bb.utils.contains('PACKAGECONFIG', 'dbus', '-DHAVE_DBUS', '', d)} \
75            ${@bb.utils.contains('PACKAGECONFIG', 'idn', '-DHAVE_IDN', '', d)} \
76            ${@bb.utils.contains('PACKAGECONFIG', 'conntrack', '-DHAVE_CONNTRACK', '', d)} \
77            ${@bb.utils.contains('PACKAGECONFIG', 'lua', '-DHAVE_LUASCRIPT', '', d)}' \
78     'CFLAGS=${CFLAGS}' \
79     'LDFLAGS=${LDFLAGS}' \
80 "
81
82 SRC_URI += "${@bb.utils.contains('PACKAGECONFIG', 'resolvconf', 'file://dnsmasq.resolvconf file://99_dnsmasq file://dnsmasq-resolvconf-helper', '', d)}"
83
84 do_compile_append() {
85     # build dhcp_release
86     cd ${S}/contrib/lease-tools
87     oe_runmake
88 }
89
90 do_install () {
91     oe_runmake "PREFIX=${D}${prefix}" \
92                "BINDIR=${D}${bindir}" \
93                "MANDIR=${D}${mandir}" \
94                install
95
96     install -d ${D}${sysconfdir}/
97     install -d ${D}${sysconfdir}/init.d
98     install -d ${D}${sysconfdir}/dnsmasq.d
99
100     install -m 644 ${S}/dnsmasq.conf.example ${D}${sysconfdir}/dnsmasq.conf
101     cat << EOF >> ${D}${sysconfdir}/dnsmasq.conf
102
103 # Include all files in /etc/dnsmasq.d except RPM backup files
104 conf-dir=/etc/dnsmasq.d,.rpmnew,.rpmsave,.rpmorig
105 EOF
106
107     install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/dnsmasq
108
109     install -d ${D}${systemd_system_unitdir}
110
111     if [ "${@bb.utils.filter('PACKAGECONFIG', 'resolvconf', d)}" ]; then
112         install -m 0644 ${WORKDIR}/dnsmasq-resolvconf.service ${D}${systemd_system_unitdir}/dnsmasq.service
113     else
114         install -m 0644 ${WORKDIR}/stx/dnsmasq.service ${D}${systemd_system_unitdir}/dnsmasq.service
115     fi
116
117     install -m 0755 ${S}/contrib/lease-tools/dhcp_release ${D}${bindir}
118     install -m 0755 ${S}/contrib/lease-tools/dhcp_release6 ${D}${bindir}
119     install -m 0755 ${S}/contrib/lease-tools/dhcp_lease_time ${D}${bindir}
120
121     if [ "${@bb.utils.filter('PACKAGECONFIG', 'dbus', d)}" ]; then
122         install -d ${D}${sysconfdir}/dbus-1/system.d
123         install -m 644 dbus/dnsmasq.conf ${D}${sysconfdir}/dbus-1/system.d/
124     fi
125     if [ "${@bb.utils.filter('PACKAGECONFIG', 'resolvconf', d)}" ]; then
126         install -d ${D}${sysconfdir}/resolvconf/update.d/
127         install -m 0755 ${WORKDIR}/dnsmasq.resolvconf ${D}${sysconfdir}/resolvconf/update.d/dnsmasq
128
129         install -d ${D}${sysconfdir}/default/volatiles
130         install -m 0644 ${WORKDIR}/99_dnsmasq ${D}${sysconfdir}/default/volatiles
131         install -m 0755 ${WORKDIR}/dnsmasq-resolvconf-helper ${D}${bindir}
132     fi
133     install -m 755 ${STX_METADATA_PATH}/files/init ${D}/${sysconfdir}/init.d/dnsmasq
134 }
135
136 DISTRO_FEATURES_BACKFILL_CONSIDERED_remove = "sysvinit"
137
138 CONFFILES_${PN} = "${sysconfdir}/dnsmasq.conf"
139
140 RPROVIDES_${PN} += "${PN}-systemd"
141 RREPLACES_${PN} += "${PN}-systemd"
142 RCONFLICTS_${PN} += "${PN}-systemd"
143 SYSTEMD_SERVICE_${PN} = "dnsmasq.service"
144 SYSTEMD_AUTO_ENABLE_${PN} = "disable"