Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-support / deltarpm / deltarpm_git.bb
1
2 DESCRIPTION = "Makedeltarpm creates a deltarpm from two rpms. The deltarpm can \
3                 later be used to recreate the new rpm from either filesystem data \
4                 or the old rpm. Use the -v option to make makedeltarpm more verbose \
5                 about its work (use it twice to make it even more verbose).\
6                 "
7 LICENSE = "BSD-3-Clause"
8 LIC_FILES_CHKSUM = "file://LICENSE.BSD;md5=574af071cf0d60a71cb781844bbe2d76"
9
10 SRCREV = "c5e0ca7482e2cfea5e4d902ffe488e0a71ed3e67"
11 # SRCREV = "8660d976f5d2b73adf1088d67341be9c3646f2f2"
12 PROTOCOL = "https"
13 BRANCH = "master"
14 S = "${WORKDIR}/git"
15 PV = "3.6.2+git${SRCPV}"
16
17 SRC_URI = "git://github.com/rpm-software-management/deltarpm.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
18                 file://0001-Makefile-patch-fix-build-errors.patch \
19                 "
20
21 DEPENDS += " python perl bzip2 rpm zlib python xz zstd"
22
23 do_compile_append () {
24         cd ${S}
25         oe_runmake -e DESTDIR=${D} bindir=${bindir} mandir=${mandir} python
26
27 }
28
29 do_install () {
30         cd ${S}
31         oe_runmake -e DESTDIR=${D} bindir=${bindir} mandir=${mandir} install
32 }
33
34 FILES_${PN}_append += " \
35         /usr/lib/python2.7/site-packages/deltarpm.py \
36         /usr/lib/python2.7/site-packages/_deltarpmmodule.so \
37         "