Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-support / boost / boost_1.69.0.bbappend
1 DEP_PYTHON = "\
2     python \
3     python-native \
4     python-numpy-native \
5     python3 \
6     python3-native \
7     python3-numpy-native \
8 "
9
10 PACKAGECONFIG = "locale python"
11 PACKAGECONFIG[python] = ",,${DEP_PYTHON}"
12
13 BJAM_OPTS += "${@bb.utils.contains('BOOST_LIBS', 'python', 'python=${PYTHON_BASEVERSION},2.7', '', d)}"
14
15 do_configure_append () {
16     if ${@bb.utils.contains('BOOST_LIBS', 'python', 'true', 'false', d)}; then
17         echo "using python : 2.7 : ${STAGING_BINDIR_NATIVE}/python-native/python : ${STAGING_INCDIR}/python2.7 : ${STAGING_LIBDIR}/python2.7 ;" >> ${WORKDIR}/user-config.jam
18         sed -i -e 's|${STAGING_DIR_HOST}${bindir}/python3|${STAGING_BINDIR_NATIVE}/python3-native/python3|' ${WORKDIR}/user-config.jam
19     fi
20 }
21
22 PACKAGES += "${PN}-python3"
23
24 FILES_${PN}-python = " \
25     ${libdir}/libboost_python2*.so.* \
26     ${libdir}/libboost_numpy2*.so.* \
27 "
28 FILES_${PN}-python3 = " \
29     ${libdir}/libboost_python3*.so.* \
30     ${libdir}/libboost_numpy3*.so.* \
31 "