Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-security / libtomcrypt / libtommath_1.1.0.bb
1
2 SUMMARY = "A portable number theoretic multiple-precision integer library"
3 DESCRIPTION = " \
4   A free open source portable number theoretic multiple-precision integer \
5   library written entirely in C. (phew!). The library is designed to provide \
6   a simple to work with API that provides fairly efficient routines that \
7   build out of the box without configuration. \
8 "
9 HOMEPAGE = "https://github.com/libtom/libtommath"
10
11 LICENSE = "PD"
12 LIC_FILES_CHKSUM = "file://LICENSE;md5=23e7e0a32e53a2b1d35f5fd9ef053402"
13
14 DEPENDS = "libtool-cross"
15
16 SRC_URI = "https://github.com/libtom/libtommath/releases/download/v${PV}/ltm-${PV}.tar.xz"
17
18 SRC_URI[md5sum] = "b2da4488c9024976d36870132f4b8a42"
19 SRC_URI[sha256sum] = "90466c88783d1fe9f5c2364a69f5479f10d73ed616011be6196f35f7f1537ead"
20
21 EXTRA_OEMAKE = " \
22         LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool \
23         LIBPATH=${libdir} \
24         INCPATH=${includedir} \
25         -f makefile.shared \
26         "
27
28 do_install() {
29         oe_runmake install DESTDIR=${D}
30 }