Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-security / libtomcrypt / libtomcrypt_1.18.2.bb
1
2 SUMMARY = "A comprehensive, portable cryptographic toolkit"
3 DESCRIPTION = " \
4   A comprehensive, modular and portable cryptographic toolkit that provides \
5   developers with a vast array of well known published block ciphers, one-way \
6   hash functions, chaining modes, pseudo-random number generators, public key \
7   cryptography and a plethora of other routines. Designed from the ground up to \
8   be very simple to use. It has a modular and standard API that allows new ciphers, \
9   hashes and PRNGs to be added or removed without change to the overall end application. \
10   It features easy to use functions and a complete user manual which has many source \
11   snippet examples. \
12 "
13 HOMEPAGE = "https://github.com/libtom/libtomcrypt"
14
15 LICENSE = "PD"
16 LIC_FILES_CHKSUM = "file://LICENSE;md5=71baacc459522324ef3e2b9e052e8180"
17
18 DEPENDS = "libtool-cross"
19
20 SRC_URI = "https://github.com/libtom/libtomcrypt/releases/download/v${PV}/crypt-${PV}.tar.xz"
21
22 SRC_URI[md5sum] = "e8d22351b7c95bef423c1cd02dcf836d"
23 SRC_URI[sha256sum] = "96ad4c3b8336050993c5bc2cf6c057484f2b0f9f763448151567fbab5e767b84"
24
25 EXTRA_OEMAKE = " \
26         LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool \
27         LIBPATH=${libdir} \
28         INCPATH=${includedir} \
29         -f makefile.shared \
30         "
31
32 do_compile() {
33         oe_runmake library
34 }
35
36 do_install() {
37         oe_runmake install DESTDIR=${D}
38 }