Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-networking / ipset / ipset_6.38.bb
1
2 SUMMARY = "Manage Linux IP sets"
3 DESCRIPTION = " \
4 IP sets are a framework inside the Linux kernel since version 2.4.x, which can  \
5 be administered by the ipset utility. Depending on the type, currently an IP \
6 set may store IP addresses, (TCP/UDP) port numbers or IP addresses with MAC \
7 addresses in a way, which ensures lightning speed when matching an entry \
8 against a set. \
9 \
10 If you want to: \
11  - store multiple IP addresses or port numbers and match against the collection \
12    by iptables at one swoop; \
13  - dynamically update iptables rules against IP addresses or ports without \
14    performance penalty; \
15  - express complex IP address and ports based rulesets with one single iptables \
16    rule and benefit from the speed of IP sets \
17 then ipset may be the proper tool for you. \
18 "
19
20 HOMEPAGE = "http://ipset.netfilter.org"
21
22 LICENSE = "GPL-2.0"
23 LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
24
25 SECTION = "network"
26
27 DEPENDS = "libtool libmnl"
28
29 SRC_URI = "http://ftp.netfilter.org/pub/ipset/${BP}.tar.bz2"
30
31 SRC_URI[md5sum] = "0e5d9c85f6b78e7dff0c996e2900574b"
32 SRC_URI[sha256sum] = "ceef625ba31fe0aaa422926c7231a819de0b07644c02c17ebdd3022a29e3e244"
33
34 inherit autotools pkgconfig module-base
35
36 EXTRA_OECONF += "-with-kbuild=${KBUILD_OUTPUT} --with-ksource=${STAGING_KERNEL_DIR}"
37
38 RDEPENDS_${PN} = "kernel-module-ip-set"
39 RRECOMMENDS_${PN} = "\
40     kernel-module-ip-set-bitmap-ip \
41     kernel-module-ip-set-bitmap-ipmac \
42     kernel-module-ip-set-bitmap-port \
43     kernel-module-ip-set-hash-ip \
44     kernel-module-ip-set-hash-ipmac \
45     kernel-module-ip-set-hash-ipmark \
46     kernel-module-ip-set-hash-ipport \
47     kernel-module-ip-set-hash-ipportip \
48     kernel-module-ip-set-hash-ipportnet \
49     kernel-module-ip-set-hash-mac \
50     kernel-module-ip-set-hash-net \
51     kernel-module-ip-set-hash-netiface \
52     kernel-module-ip-set-hash-netnet \
53     kernel-module-ip-set-hash-netport \
54     kernel-module-ip-set-hash-netportnet \
55     kernel-module-ip-set-list-set \
56 "