Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-extended / logrotate / logrotate_%.bbappend
1 inherit stx-metadata
2
3 STX_REPO = "config-files"
4 STX_SUBPATH = "logrotate-config"
5
6 LICENSE_append = "& Apache-2.0"
7 LIC_FILES_CHKSUM += "\
8         file://${STX_METADATA_PATH}/files/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
9         "
10
11 RDEPENDS_${PN}_append = " cronie"
12
13 do_install_append() {
14     install -d -m0755 ${D}/${sysconfdir}/cron.d/
15     install -m 644 ${STX_METADATA_PATH}/files/logrotate-cron.d ${D}/${sysconfdir}/cron.d/logrotate
16     install -m 644 ${STX_METADATA_PATH}/files/logrotate.conf ${D}/${sysconfdir}/logrotate.conf
17     #mv ${D}/${sysconfdir}/cron.daily/logrotate ${D}/${sysconfdir}/logrotate.cron
18     #chmod 700 ${D}/${sysconfdir}/logrotate.cron
19 }
20