Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-extended / iptables / iptables_%.bbappend
1 inherit stx-metadata
2
3 STX_REPO = "config-files"
4 STX_SUBPATH = "iptables-config"
5
6 LICENSE_append = "& Apache-2.0"
7 LIC_FILES_CHKSUM += "\
8         file://${STX_METADATA_PATH}/files/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
9         "
10
11 inherit systemd
12 SYSTEMD_PACKAGES += "${PN}"
13 SYSETMD_SERVICE_${PN}_append = "iptables.service ip6tables.service"
14 SYSTEMD_AUTO_ENABLE_${PN} = "enable"
15 DISTRO_FEATURES_BACKFILL_CONSIDERED_remove = "sysvinit"
16
17 do_install_append() {
18     install -d -m0755 ${D}/${sysconfdir}/sysconfig
19     install -m 600 ${STX_METADATA_PATH}/files/iptables.rules ${D}/${sysconfdir}/sysconfig/iptables
20     install -m 600 ${STX_METADATA_PATH}/files/ip6tables.rules ${D}/${sysconfdir}/sysconfig/ip6tables
21 }