Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python3-redfishtool_git.bb
1
2 DESCRIPTION = "Client side API implementation of the Redfish RESTful API for Data Center Hardware Management."
3 HOMEPAGE = "https://github.com/DMTF/Redfishtool"
4 SECTION = "devel/python"
5 LICENSE = "BSD-3-Clause"
6 LIC_FILES_CHKSUM = "file://LICENSE.md;md5=cee7a7694b5bf14bc9d3e0fbe78a64af"
7
8
9 SRCREV = "2bdcd905e1ad227f40809ec298804d5401047612"
10 SRCNAME = "Redfishtool"
11 BRANCH = "master"
12 PROTOCOL = "https"
13 PV = "1.1.0+git${SRCPV}"
14 S = "${WORKDIR}/git"
15
16 SRC_URI = "git://github.com/DMTF/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
17
18 inherit setuptools3
19
20 RDEPENDS_${PN} += " \
21         python3-requests \
22 "
23
24 do_install_append() {
25         :
26 }
27
28 FILES_${PN} += " \
29         "