Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python3-prettytable_0.7.2.bb
1
2 # Update log with the message: adopted from upstream e1f2e1ae5f27d889e3d4bef1b23edcf8a6d804c0
3 DESCRIPTION = " \
4         PrettyTable is a simple Python library designed to make it quick and easy to represent tabular data \
5         in visually appealing ASCII tables. It was inspired by the ASCII tables used in the PostgreSQL shell \
6         psql. PrettyTable allows for selection of which columns are to be printed, independent alignment of \
7         columns (left or right justified or centred) and printing of “sub-tables” by specifying a row range.\
8         "
9
10 LICENSE = "BSD"
11 LIC_FILES_CHKSUM = "file://COPYING;md5=3e73500ffa52de5071cff65990055282"
12
13 SRC_URI[md5sum] = "0c1361104caff8b09f220748f9d69899"
14 SRC_URI[sha256sum] = "a53da3b43d7a5c229b5e3ca2892ef982c46b7923b51e98f0db49956531211c4f"
15
16 SRCNAME = "prettytable"
17
18 SRC_URI = "https://pypi.python.org/packages/source/P/PrettyTable/${SRCNAME}-${PV}.zip"
19
20 S = "${WORKDIR}/${SRCNAME}-${PV}"
21
22 inherit setuptools3
23 do_install_append() {
24     find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "*.txt" -o -name "PKG-INFO" -exec chmod 644 {} +
25 }
26
27 BBCLASSEXTEND = "native nativesdk"