Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python3-pecan_git.bb
1
2 DESCRIPTION = "WSGI object-dispatching web framework"
3
4 HOMEPAGE = "https://pypi.python.org/pypi/pecan/"
5 SECTION = "devel/python"
6 LICENSE = "BSD-3-Clause"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=d846877d24bbb3d7a00a985c90378e8c"
8
9 SRCREV = "da15e06d783e2cf569b39ba506e68e4e1e85568d"
10 PROTOCOL = "https"
11 BRANCH = "master"
12 S = "${WORKDIR}/git"
13 PV = "1.3.2+git${SRCPV}"
14
15 SRC_URI = "git://github.com/pecan/pecan.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
16
17
18 inherit setuptools3 distutils3
19
20 RDEPENDS_${PN} = "python3-mako \
21                   python3-six \
22                   python3-logutils \
23                   python3-webtest  \
24                   "
25
26 do_install_append() {
27         mv ${D}/${bindir}/gunicorn_pecan ${D}/${bindir}/gunicorn_pecan3
28         mv ${D}/${bindir}/pecan ${D}/${bindir}/pecan3
29 }