Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python3-lang_git.bb
1
2 SUMMARY = " Lang - Python Language Constraints"
3 DESCRIPTION = "\
4         Lang is a Python module that allows enforcing programming language constraints. Lang was \
5         built using a Java like mindset, so many of the constraints that are supported are mirrors \
6         of constraints in the Java programming language. \
7         "
8
9
10 LICENSE = "Apache-2.0"
11 LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
12
13 SRCREV = "feb4c638ebc581d9913f440965e83558fd10018c"
14 PROTOCOL = "https"
15 BRANCH = "master"
16 S = "${WORKDIR}/git/src"
17 PV = "1.0.4+git${SRCPV}"
18
19 SRC_URI = "git://github.com/amitassaraf/lang.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
20
21
22 DEPENDS += " python3 python3-setuptools-scm-native"
23 inherit setuptools3 distutils3 pkgconfig