Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python3-cheroot_git.bb
1
2 SUMMARY = "Cheroot is the high-performance, pure-Python HTTP server used by CherryPy."
3
4 LICENSE = "BSD-3-Clause"
5 LIC_FILES_CHKSUM = "file://LICENSE.md;md5=beeffd9dfcc746ed5a91921f1acc2746"
6
7 SRCREV = "c7ca7ff0bcebb53e1bed783280a3bb5db35f900f"
8 PROTOCOL = "https"
9 BRANCH = "master"
10 S = "${WORKDIR}/git"
11 PV = "7.0.0"
12
13 SRC_URI = "git://github.com/cherrypy/cheroot.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
14
15
16 DEPENDS += " \
17         python3 \
18         python3-setuptools-scm-native \
19         python3-setuptools-scm-git-archive-native \
20         "
21
22 RDEPENDS_${PN} += " \
23         python3-email \
24         python3-fcntl \
25         python3-io \
26         python3-logging \
27         python3-unixadmin \
28         python3-pyopenssl \
29         python3-six \
30         "
31
32 inherit setuptools3 distutils3 pkgconfig