Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-saharaclient_git.bb
1
2 DESCRIPTION = "CLI and python client library for OpenStack Sahara"
3 HOMEPAGE = "https://launchpad.net/sahara"
4 SECTION = "devel/python"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
7
8 DEPENDS += " \
9         python-pip \
10         python-pbr \
11         "
12
13 # Satisfy setup.py 'setup_requires'
14 DEPENDS += " \
15         python-pbr-native \
16 "
17
18 RDEPENDS_${PN} += " \
19         python-pbr \
20         "
21
22 SRCNAME = "saharaclient"
23
24 SRC_URI = "git://github.com/openstack/python-saharaclient.git;branch=master"
25
26 PV = "2.3.0+git${SRCPV}"
27 SRCREV = "3107b452467537f4eef3d9ecfb5e35d110d19662"
28 S = "${WORKDIR}/git"
29
30 inherit setuptools
31