Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-ryu_git.bb
1
2 DESCRIPTION = "Ryu is a component-based software defined networking framework."
3 HOMEPAGE = "https://github.com/osrg/ryu"
4 SECTION = "devel/python"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = " \
7         file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57\
8         "
9
10 SRCREV = "1c008060fa3dab51c3a59c1485a7529b13cf0dd1"
11 SRCNAME = "ryu"
12 BRANCH = "master"
13 PROTOCOL = "https"
14 PV = "4.24+git${SRCPV}"
15 S = "${WORKDIR}/git"
16
17 SRC_URI = "git://github.com/osrg/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
18
19 inherit setuptools python-dir
20
21 DEPENDS += " \
22         python-pip \
23         python-pbr-native \
24         "
25
26 RDEPENDS_${PN}_append = " \
27         ${PYTHON_PN}-eventlet \
28         ${PYTHON_PN}-msgpack \
29         ${PYTHON_PN}-netaddr \
30         ${PYTHON_PN}-oslo.config \
31         ${PYTHON_PN}-ovs \
32         ${PYTHON_PN}-routes \
33         ${PYTHON_PN}-six \
34         ${PYTHON_PN}-tinyrpc \
35         ${PYTHON_PN}-webob \
36         "
37
38 FILES_${PN}_append = " \
39         ${datadir}/etc/${SRCNAME} \
40         "