Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-redfishtool_git.bb
1
2 DESCRIPTION = "Client side API implementation of the Redfish RESTful API for Data Center Hardware Management."
3 HOMEPAGE = "https://github.com/DMTF/Redfishtool"
4 SECTION = "devel/python"
5 LICENSE = "BSD-3-Clause"
6 LIC_FILES_CHKSUM = "file://LICENSE.md;md5=cee7a7694b5bf14bc9d3e0fbe78a64af"
7
8
9 SRCREV = "2bdcd905e1ad227f40809ec298804d5401047612"
10 SRCNAME = "Redfishtool"
11 BRANCH = "master"
12 PROTOCOL = "https"
13 PV = "1.1.0+git${SRCPV}"
14 S = "${WORKDIR}/git"
15
16 SRC_URI = " \
17         git://github.com/DMTF/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
18         file://${PN}/0001-Adapt-redfishtool-to-python2.patch \
19         "
20
21 inherit setuptools
22
23 RDEPENDS_${PN} += " \
24         python-requests \
25 "
26
27 do_install_append() {
28         :
29 }
30
31 FILES_${PN} += " \
32         "