Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-pysaml2_git.bb
1
2 DESCRIPTION = "Python implementation of SAML Version 2 to be used in a WSGI environment"
3 HOMEPAGE = "https://github.com/rohe/pysaml2"
4 SECTION = "devel/python"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=861cc9087857b5bea2e11356c3de95d9"
7
8 SRCREV = "c740a3a270037d6fcb42a12112db594705d3878f"
9 SRCNAME = "pysaml2"
10 PROTOCOL = "git"
11 BRANCH = "v4.9.0"
12 S = "${WORKDIR}/git"
13 PV = "4.5.0+git${SRCPV}"
14
15 SRC_URI = "git://github.com/rohe/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
16
17 inherit setuptools
18
19 DEPENDS += " \
20         python-pip \
21         "
22
23 RDEPENDS_${PN} += " \
24         python-zopeinterface \
25         python-repoze.who \
26         python-defusedxml \
27         "