Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-osprofiler_git.bb
1
2 DESCRIPTION = "Library for cross-project profiling library"
3 HOMEPAGE = "https://docs.openstack.org/osprofiler/latest/"
4 SECTION = "devel/python"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=19cbd64715b51267a47bf3750cc6a8a5"
7
8 SRCREV = "6d68170f72ef303e6564e164aafb1ec53a8b8314"
9 SRCNAME = "osprofiler"
10 BRANCH = "master"
11 PROTOCOL = "https"
12 PV = "2.3.0+git${SRCPV}"
13 S = "${WORKDIR}/git"
14
15 SRC_URI = "git://opendev.org/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
16         
17 inherit setuptools
18
19 DEPENDS += " python-pbr-native"
20
21 RDEPENDS_${PN}_append = " \
22         python-pbr \
23         python-six \
24         python-oslo.messaging \
25         python-oslo.log \
26         python-oslo.utils \
27         python-webob \
28         python-requests \
29         python-netaddr \
30         python-oslo.concurrency \
31         "