Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-oslo.versionedobjects_git.bb
1
2 DESCRIPTION = "Oslo versionedobjects library"
3 HOMEPAGE = "https://wiki.openstack.org/wiki/Oslo"
4 SECTION = "devel/python"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
7
8 SRCREV = "c95f0c876840e36f37acb14d5eec5238d85e7dce"
9 SRCNAME = "oslo.versionedobjects"
10 PROTOCOL = "https"
11 BRANCH = "stable/queens"
12 S = "${WORKDIR}/git"
13 PV = "1.31.2+git${SRCPV}"
14
15 SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
16
17 inherit setuptools
18
19 DEPENDS += " \
20         python-pip \
21         python-pbr-native \
22         "
23
24 RDEPENDS_${PN} += " \
25         python-six \
26         python-oslo.concurrency \
27         python-oslo.config \
28         python-oslo.context \
29         python-oslo.messaging \
30         python-oslo.serialization \
31         python-oslo.utils \
32         python-oslo.log \
33         python-oslo.i18n \
34         python-webob \
35         python-iso8601 \
36         python-netaddr \
37        "