Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-oslo.upgradecheck_git.bb
1
2 SUMMARY = "Common code for writing OpenStack upgrade checks"
3 DESCRIPTION = "\
4   This project contains the common code necessary for writing upgrade checks \
5   in OpenStack projects. It includes a module (oslo_upgradecheck.upgradecheck) \
6   for the common code as well as an example (oslo_upgradecheck.__main__) of \
7   integrating that code into a project. \
8 "
9 HOMEPAGE = "https://github.com/openstack/oslo.upgradecheck"
10 SECTION = "devel/python"
11
12 LICENSE = "Apache-2.0"
13 LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
14
15 PV = "0.3.1+git${SRCPV}"
16 SRCREV = "5f182fe19cdfe0bcf0d51bcf7be05e7a74f0a068"
17
18 SRCNAME = "oslo.upgradecheck"
19 SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master"
20
21 S = "${WORKDIR}/git"
22
23 inherit setuptools
24
25 DEPENDS += " \
26     python-pip \
27     python-pbr-native \
28 "
29
30 RDEPENDS_${PN} += " \
31     python-oslo.config \
32     python-oslo.i18n \
33 "