Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-oslo.serialization_git.bb
1
2 DESCRIPTION = "Oslo Serialization API"
3 HOMEPAGE = "https://launchpad.net/oslo"
4 SECTION = "devel/python"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
7
8 SRCREV = "576b13ec26baa671da05df56a8d14aba6fa3e826"
9 SRCNAME = "oslo.serialization"
10 PROTOCOL = "https"
11 BRANCH = "stable/train"
12 S = "${WORKDIR}/git"
13 PV = "2.23.0+git${SRCPV}"
14
15 SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
16
17
18 inherit setuptools
19
20 # DEPENDS_default: python-pip
21
22 DEPENDS += " \
23         python-pip \
24         python-pbr-native\
25         "
26
27 # Satisfy setup.py 'setup_requires'
28 DEPENDS += " \
29         python-pbr-native \
30         "
31
32 # RDEPENDS_default:
33 RDEPENDS_${PN} += " \
34         python-pbr \
35         python-six \
36         python-oslo.utils \
37         python-pytz \
38         python-msgpack \
39         "