Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-oslo.policy_git.bb
1
2 DESCRIPTION = "Oslo policy library"
3 HOMEPAGE = "https://github.com/openstack/oslo.policy"
4 SECTION = "devel/python"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
7
8 SRCREV = "b9fd10e2612f26c93d49c168a0408aba6d20e5bf"
9 SRCNAME = "oslo.policy"
10 PROTOCOL = "https"
11 BRANCH = "stable/train"
12 S = "${WORKDIR}/git"
13 PV = "1.43.1+git${SRCPV}"
14
15 SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
16
17 inherit setuptools
18
19 DEPENDS += " \
20         python-pip \
21         python-pbr-native \
22         "
23
24 RDEPENDS_${PN} += " \
25         python-oslo.config \
26         python-oslo.i18n \
27         python-oslo.serialization \
28         python-oslo.utils \
29         python-six \
30         python-pyyaml \
31         python-requests \
32         "