Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-oslo.middleware_git.bb
1
2 DESCRIPTION = "Oslo Middleware Library"
3 HOMEPAGE = "https://launchpad.net/oslo"
4 SECTION = "devel/python"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
7
8 SRCREV = "8812bc3fc490f0db4977418eaedf58190a0df394"
9 SRCNAME = "oslo.middleware"
10 PROTOCOL = "https"
11 BRANCH = "stable/train"
12 S = "${WORKDIR}/git"
13 PV = "3.31.0+git${SRCPV}"
14
15 SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
16
17 inherit setuptools
18
19 DEPENDS += " \
20         python-pip \
21         python-pbr-native \
22         "
23
24 # Satisfy setup.py 'setup_requires'
25 DEPENDS += " \
26         python-pbr-native \
27         "
28
29 # RDEPENDS_default:
30 RDEPENDS_${PN} += " \
31         python-pbr \
32         python-jinja2 \
33         python-oslo.config \
34         python-oslo.context \
35         python-oslo.i18n \
36         python-oslo.utils \
37         python-six \
38         python-stevedore \
39         python-webob \
40         python-debtcollector \
41         python-statsd \
42         "