Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-oslo.log_git.bb
1
2 DESCRIPTION = "Oslo Log Library"
3 HOMEPAGE = "https://launchpad.net/oslo"
4 SECTION = "devel/python"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
7
8 SRCREV = "e19c4076b1f0d7fdbd6d68a09c973934029926a1"
9 SRCNAME = "oslo.log"
10 PROTOCOL = "https"
11 BRANCH = "stable/train"
12 S = "${WORKDIR}/git"
13 PV = "3.44.3+git${SRCPV}"
14
15 SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
16
17 inherit setuptools
18
19 DEPENDS += " \
20         python-pip \
21         python-babel \
22         python-pbr-native \
23         "
24
25 # Satisfy setup.py 'setup_requires'
26 DEPENDS += " \
27         python-pbr-native \
28         "
29
30 # RDEPENDS_default: 
31 RDEPENDS_${PN} += " \
32         bash \
33         python-pbr \
34         python-six \
35         python-oslo.config \
36         python-oslo.context \
37         python-oslo.i18n \
38         python-oslo.utils \
39         python-oslo.serialization \
40         python-pyinotify \
41         python-debtcollector \
42         python-dateutil \
43         python-monotonic \
44         "