Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-oslo.db_git.bb
1
2 DESCRIPTION = "Oslo db library"
3 HOMEPAGE = "http://launchpad.net/oslo"
4 SECTION = "devel/python"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
7
8 SRCREV = "4de33ebd504a2c3dbddc2492bdb96ae7bca77d66"
9 SRCNAME = "oslo.db"
10 PROTOCOL = "https"
11 BRANCH = "stable/stein"
12 S = "${WORKDIR}/git"
13 PV = "4.27.0+git${SRCPV}"
14
15 SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
16
17 inherit setuptools
18
19 DEPENDS += " \
20         python-pip \
21         python-pbr-native \
22         "
23
24 RDEPENDS_${PN} += " \
25         python-oslo.config \
26         python-oslo.i18n \
27         python-oslo.serialization \
28         python-oslo.utils \
29         python-six \
30         python-alembic \
31         python-sqlalchemy \
32         python-sqlalchemy-migrate \
33         python-stevedore \
34         python-pbr \
35         python-debtcollector \
36         "