Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-oslo.context_git.bb
1
2 DESCRIPTION = "Oslo Context Library"
3 HOMEPAGE = "https://launchpad.net/oslo"
4 SECTION = "devel/python"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
7
8 SRCREV = "76a07f9022f0fa967707c9f6cb5a4a24aac6b3ef"
9 SRCNAME = "oslo.context"
10 PROTOCOL = "https"
11 BRANCH = "stable/stein"
12 S = "${WORKDIR}/git"
13 PV = "2.22.1+git${SRCPV}"
14
15 SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
16
17 inherit setuptools
18
19 DEPENDS += " \
20         python-pip \
21         python-pbr-native \
22         "
23
24 # Satisfy setup.py 'setup_requires'
25 DEPENDS += " \
26         python-pbr-native \
27         "
28
29 # RDEPENDS_default: 
30 RDEPENDS_${PN} += " \
31         bash \
32         python-pbr \
33         python-debtcollector \
34         python-positional \
35         "