Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-oslo.config_git.bb
1
2 DESCRIPTION = "API supporting parsing command line arguments and .ini style configuration files."
3 HOMEPAGE = "https://pypi.python.org/pypi/oslo.config/5.2.0"
4 SECTION = "devel/python"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=c46f31914956e4579f9b488e71415ac8"
7
8 SRCREV = "31c11ab4289efa1a91835f3daa928fe927ac4276"
9 SRCNAME = "oslo.config"
10 PROTOCOL = "https"
11 BRANCH = "stable/queens"
12 S = "${WORKDIR}/git"
13 PV = "5.2.0+git${SRCPV}"
14
15 SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
16
17 inherit setuptools rmargparse
18
19 DEPENDS += " \
20         python-pbr \
21         python-pip \
22         "
23
24 # Satisfy setup.py 'setup_requires'
25 DEPENDS += " \
26         python-pbr-native \
27         "
28
29 RDEPENDS_${PN} += " \
30     python-pbr \
31     python-netaddr \
32     python-six \
33     python-stevedore \
34     python-debtcollector \
35     python-oslo.i18n \
36     python-rfc3986 \
37     python-pyyaml \
38     python-importlib-metadata \
39     "
40