Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-oslo.concurrency_git.bb
1
2 DESCRIPTION = "oslo.concurrency library"
3 HOMEPAGE = "https://github.com/openstack/oslo.concurrency"
4 SECTION = "devel/python"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
7
8 SRCREV = "5b42d276350666410a7d010a5152467ad509d3f9"
9 SRCNAME = "oslo.concurrency"
10 PROTOCOL = "https"
11 BRANCH = "stable/train"
12 S = "${WORKDIR}/git"
13 PV = "3.26.0+git${SRCPV}"
14
15 SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
16
17 inherit setuptools rmargparse
18
19 DEPENDS += " \
20         python-pbr \
21         python-pip \
22         "
23
24 DEPENDS += " \
25         python-pbr-native \
26         "
27
28 # RDEPENDS_default:
29 RDEPENDS_${PN} += " \
30         python-pbr \
31         python-fasteners \
32         python-oslo.config \
33         python-oslo.i18n \
34         python-oslo.utils \
35         python-six \
36         python-enum34 \
37         "