Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-oslo.cache_git.bb
1
2 DESCRIPTION = "oslo.config enabled dogpile cache"
3 HOMEPAGE = "https://github.com/openstack/oslo.cache"
4 SECTION = "devel/python"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
7
8 SRCREV = "3b8d9c3f6c87d62e5502cf4a9ae89e4067180c1f"
9 SRCNAME = "oslo.cache"
10 PROTOCOL = "https"
11 BRANCH = "stable/train"
12 S = "${WORKDIR}/git"
13 PV = "1.26.0+git${SRCPV}"
14
15 SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
16
17 inherit setuptools rmargparse
18
19 DEPENDS += " \
20         python-pbr \
21         python-pip \
22         "
23
24 DEPENDS += " \
25         python-pbr-native \
26         "
27
28 # RDEPENDS_default:
29 RDEPENDS_${PN} += " \
30         python-dogpile.cache \
31         python-six \
32         python-oslo.config \
33         python-oslo.i18n \
34         python-oslo.log \
35         python-oslo.utils \
36         "