Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-osc-lib_1.14.1.bb
1
2 DESCRIPTION = "OpenStackClient Library"
3 HOMEPAGE = "http://opensource.perlig.de/rcssmin/"
4 SECTION = "devel/python"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
7
8 SRC_URI[md5sum] = "240d3debc1b6eaadf5e8838f5f2d06fb"
9 SRC_URI[sha256sum] = "3467a1edf62946f1b67724fa7f9c699b5e31d80b111ed9e4c7aec21633a3e30d"
10
11 inherit setuptools pypi
12
13 # Satisfy setup.py 'setup_requires'
14 DEPENDS += " \
15         python-pbr-native \
16         "
17
18 RDEPENDS_${PN} += " \
19         python-pbr \
20         python-six \
21         python-babel \
22         python-cliff \
23         python-keystoneauth1 \
24         python-os-client-config \
25         python-oslo.i18n \
26         python-oslo.utils \
27         python-simplejson \
28         python-stevedore \
29         "
30
31 CLEANBROKEN = "1"