Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-ldap_3.2.0.bb
1 #
2 # Copyright (C) 2012 Wind River Systems, Inc.
3 #
4 SUMMARY = "Provides a wrapper in Python to LDAP"
5 DESCRIPTION = "This module provides access to the LDAP \
6 (Lightweight Directory Access Protocol) through Python operations \
7 instead of C API. The module mainly acts as a wrapper for the \
8 OpenLDAP 2.x libraries. Errors will appear as exceptions."
9
10 LICENSE = "PSF"
11 HOMEPAGE = "http://www.python-ldap.org/"
12 DEPENDS = "python openldap cyrus-sasl"
13
14 PYPI_PACKAGE = "python-ldap"
15 inherit pypi setuptools
16
17 LIC_FILES_CHKSUM = "file://LICENCE;md5=36ce9d726d0321b73c1521704d07db1b"
18 SRC_URI[md5sum] = "fe22522208dc9b06d16eb70f8553eaab"
19 SRC_URI[sha256sum] = "7d1c4b15375a533564aad3d3deade789221e450052b21ebb9720fb822eccdb8e"
20
21 do_configure_prepend() {
22     sed -i -e 's:^library_dirs =.*::' setup.cfg
23     sed -i -e 's:^include_dirs =.*:include_dirs = =/usr/include/sasl/:' setup.cfg
24 }
25
26 RDEPENDS_${PN} = " \
27     ${PYTHON_PN}-pprint \
28     ${PYTHON_PN}-threading \
29     ${PYTHON_PN}-pyasn1 \
30     ${PYTHON_PN}-pyasn1-modules \
31 "