Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-keystonemiddleware_git.bb
1
2 DESCRIPTION = "Middleware for Openstack identity API"
3 HOMEPAGE = "https://launchpad.net/keystonemiddleware"
4 SECTION = "devel/python"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=4a4d0e932ffae1c0131528d30d419c55"
7
8 SRCREV = "0a65b1420799e7c7f8736e9f6c234f755ab5ac6b"
9 SRCNAME = "keystonemiddleware"
10 BRANCH = "stable/train"
11 PROTOCOL = "https"
12 PV = "7.0.1+git${SRCPV}"
13 S = "${WORKDIR}/git"
14
15 SRC_URI = "git://git.openstack.org/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
16
17
18 inherit setuptools
19
20 DEPENDS += " \
21         python-pip \
22         python-pbr-native \
23         "
24
25 # Satisfy setup.py 'setup_requires'
26 DEPENDS += " \
27         python-pbr-native \
28         "
29
30 RDEPENDS_${PN} += " \
31         python-keystoneauth1 \
32         python-oslo.cache \
33         python-oslo.config \
34         python-oslo.context \
35         python-oslo.i18n \
36         python-oslo.log \
37         python-oslo.serialization \
38         python-oslo.utils \
39         python-pbr \
40         python-positional \
41         python-pycadf \
42         python-keystoneclient \
43         python-requests \
44         python-six \
45         python-webob \
46         "