Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-ironicclient_git.bb
1
2 DESCRIPTION = "python-ironicclient"
3 SECTION = "devel/python"
4
5 SRCREV = "04ef2d7b04caad162e299c52542b2cb581552ea3"
6 SRCNAME = "python-ironicclient"
7 PROTOCOL = "https"
8 BRANCH = "stable/train"
9 PV = "3.1.0+git${SRCPV}"
10 S = "${WORKDIR}/git"
11
12 LICENSE = "Apache-2.0"
13 LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
14
15 SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
16
17 DEPENDS += " \
18         python \
19         python-pbr-native \
20         "
21
22 inherit setuptools
23
24 RDEPENDS_${PN}_append = " \
25         bash \
26         python-dogpile.cache \
27         python-oslo.config \
28         "