Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-importlib-metadata_0.23.bb
1
2 SUMMARY = "Read metadata from Python packages"
3 DESCRIPTION = "Read metadata from Python packages"
4 HOMEPAGE = "https://pypi.org/project/importlib-metadata/"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=e88ae122f3925d8bde8319060f2ddb8e"
7
8 SRC_URI[md5sum] = "80d677d744995336c9c22d21a85ddeb8"
9 SRC_URI[sha256sum] = "aa18d7378b00b40847790e7c27e11673d7fed219354109d0e7b9e5b25dc3ad26"
10
11 DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
12
13 PYPI_PACKAGE = "importlib_metadata"
14
15 inherit pypi setuptools
16
17 S = "${WORKDIR}/importlib_metadata-${PV}"
18
19 RDEPENDS_${PN} += "\
20     ${PYTHON_PN}-zipp \
21     ${PYTHON_PN}-pathlib2 \
22     python-compression \
23     python-configparser \
24     python-contextlib2 \
25     python-pathlib2 \
26 "
27
28 BBCLASSEXTEND = "native nativesdk"