Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-glanceclient_git.bb
1
2 DESCRIPTION = "Client library for Glance built on the OpenStack Images API."
3 HOMEPAGE = "https://opendev.org/openstack/python-glanceclient"
4 SECTION = "devel/python"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
7
8 SRCREV = "40c19aa44361e13ac997d325d357d3e4748fa063"
9 SRCNAME = "python-glanceclient"
10 BRANCH = "stable/train"
11 PROTOCOL = "https"
12 PV = "2.17.0+git${SRCPV}"
13 S = "${WORKDIR}/git"
14
15 SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
16         
17 inherit setuptools monitor rmargparse
18
19 DEPENDS += " \
20         python-pip \
21         python-pbr-native\
22         "
23
24 # Satisfy setup.py 'setup_requires'
25 DEPENDS += " \
26         python-pbr-native \
27         "
28
29 RDEPENDS_${PN} += " \
30         bash \
31         python-pbr \
32         python-prettytable \
33         python-keystoneauth1 \
34         python-warlock \
35         python-six \
36         python-oslo.utils \
37         python-oslo.i18n \
38         python-wrapt \
39         python-pyopenssl \
40         "
41
42
43 do_install_append() {
44         install -d -m 755 ${D}/${sysconfdir}/bash_completion.d
45         install -p -D -m 664 tools/glance.bash_completion ${D}/${sysconfdir}/bash_completion.d/glance
46 }