Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-futurist_1.8.1.bb
1
2 DESCRIPTION = "Useful additions to futures, from the future"
3 HOMEPAGE = "https://pypi.python.org/pypi/futurist"
4 SECTION = "devel/python"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
7
8 SRC_URI[md5sum] = "3e5a4b8254ded1624ec807cb7ae04ba5"
9 SRC_URI[sha256sum] = "499ee57728a987028725f836ac22aa18899702162fa0a0f1bbe2ecd5c8daf1eb"
10
11 inherit setuptools pypi
12
13 DEPENDS += " \
14         python-pip \
15         python-pbr-native \
16         "
17
18 RDEPENDS_${PN} += " \
19         python-pbr \
20         python-six \
21         python-monotonic \
22         python-futures \
23         python-contextlib2 \
24         python-prettytable \
25         "
26