Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-django-horizon_15.1.0.bb
1
2 DESCRIPTION = "Simple database sharding (horizontal partitioning) library for Django applications."
3 HOMEPAGE = "http://horizon.openstack.org/"
4 SECTION = "devel/python"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
7
8 inherit setuptools 
9
10 SRC_URI[md5sum] = "21c32ba58806b351ede4eca6804e6d3e"
11 SRC_URI[sha256sum] = "25cf663f8f9a0233edbd5ba322acc28805fca684df28290c3e62a79abf6724e9"
12
13 S = "${WORKDIR}/horizon-${PV}"
14
15 SRC_URI = "https://tarballs.openstack.org/horizon/horizon-${PV}.tar.gz"
16
17 DEPENDS += " \
18         python-pip \
19         python-pbr-native \
20         "
21
22
23 RDEPENDS_${PN} = " \
24         python-pbr \
25         python-babel \
26         python-django \
27         python-django \
28         python-django-babel \
29         python-django-compressor \
30         python-django-debreach \
31         python-django-pyscss \
32         python-futurist \
33         python-iso8601 \
34         python-keystoneauth1 \
35         python-netaddr \
36         python-oslo.concurrency \
37         python-oslo.config \
38         python-oslo.i18n \
39         python-oslo.policy \
40         python-oslo.serialization \
41         python-oslo.upgradecheck \
42         python-oslo.utils \
43         python-osprofiler \
44         python-pint \
45         python-pymongo \
46         python-pyscss \
47         python-cinderclient \
48         python-glanceclient \
49         python-keystoneclient \
50         python-neutronclient \
51         python-novaclient \
52         python-swiftclient \
53         python-pytz \
54         python-pyyaml \
55         python-requests \
56         python-semantic-version \
57         python-six \
58         python-xstatic \
59         python-xstatic-angular \
60         python-xstatic-angular-bootstrap \
61         python-xstatic-angular-fileupload \
62         python-xstatic-angular-gettext \
63         python-xstatic-angular-lrdragndrop \
64         python-xstatic-angular-schema-form \
65         python-xstatic-bootstrap-datepicker \
66         python-xstatic-bootstrap-scss \
67         python-xstatic-bootswatch \
68         python-xstatic-d3 \
69         python-xstatic-hogan \
70         python-xstatic-font-awesome \
71         python-xstatic-jasmine \
72         python-xstatic-jquery \
73         python-xstatic-jquery-migrate \
74         python-xstatic-jquery.quicksearch \
75         python-xstatic-jquery.tablesorter \
76         python-xstatic-jquery-ui \
77         python-xstatic-jsencrypt \
78         python-xstatic-mdi \
79         python-xstatic-objectpath \
80         python-xstatic-mdi \
81         python-xstatic-objectpath \
82         python-xstatic-rickshaw \
83         python-xstatic-roboto-fontface \
84         python-xstatic-smart-table \
85         python-xstatic-spin \
86         python-xstatic-term.js \
87         python-xstatic-tv4 \
88         "