Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-cliff_2.14.1.bb
1
2 DESCRIPTION = "Command Line Interface Formulation Framework"
3 HOMEPAGE = "https://github.com/dreamhost/cliff"
4 SECTION = "devel/python"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
7
8 SRC_URI[md5sum] = "4c5d43d98970c79b091e25676cce2b10"
9 SRC_URI[sha256sum] = "b47387a344898ccb28ca7f386f017ade9eb66dc1713e5c642a0bc09ec606cc67"
10
11 inherit setuptools pypi
12
13 DEPENDS += "\
14     python-pbr \
15     "
16
17 # Satisfy setup.py 'setup_requires'
18 DEPENDS += " \
19     python-pbr-native \
20     "
21
22 RDEPENDS_${PN} += "python-prettytable \
23             python-cmd2 \
24             python-pbr \
25             python-pyparsing \
26             python-prettytable \
27             python-six \
28             python-stevedore \
29             python-unicodecsv \
30             python-pyyaml \
31 "
32
33 CLEANBROKEN = "1"