Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-cinderclient_git.bb
1
2 DESCRIPTION = "Client for the OpenStack Cinder API"
3 HOMEPAGE = "https://opendev.org/openstack/python-cinderclient"
4 SECTION = "devel/python"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=3572962e13e5e739b30b0864365e0795"
7
8 SRCREV = "a63d4d651ae2f7614224f716b3ef8ebf392a6b78"
9 SRCNAME = "python-cinderclient"
10 BRANCH = "stable/train"
11 PROTOCOL = "https"
12 PV = "5.0.0+git${SRCPV}"
13 S = "${WORKDIR}/git"
14
15 SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
16
17 inherit setuptools
18
19 DEPENDS += " \
20         python-pip \
21         python-pbr-native\
22         "
23
24 # Satisfy setup.py 'setup_requires'
25 DEPENDS += " \
26         python-pbr-native \
27         "
28
29 RDEPENDS_${PN} += " \
30         bash \
31         python-pbr \
32         python-prettytable \
33         python-keystoneauth1 \
34         python-oslo.i18n \
35         python-oslo.utils \
36         python-six \
37         python-osc-lib \
38         python-babel \
39         python-requests \
40         python-simplejson \
41         "
42
43
44 do_install_append() {
45         install -d -m 755 ${D}/${sysconfdir}/bash_completion.d
46         install -p -D -m 664 tools/cinder.bash_completion ${D}/${sysconfdir}/bash_completion.d/cinder.bash_completion
47          
48 }