Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-cherrypy_3.2.2.bb
1 SUMMARY = " CherryPy is a pythonic, object-oriented HTTP framework"
2 DESCRIPTION = "\
3 It allows building web applications in much the same way one would build any \
4 other object-oriented program. This design results in less and more readable \
5 code being developed faster. It's all just properties and methods. \
6 It is now more than ten years old and has proven fast and very stable. \
7 It is being used in production by many sites, from the simplest to the most \
8 demanding. \
9 "
10
11 HOMEPAGE = "https://www.cherrypy.org/"
12 AUTHOR = "CherryPy Team"
13
14 LICENSE = "BSD"
15 LIC_FILES_CHKSUM = "file://cherrypy/LICENSE.txt;md5=c187ff3653a0878075713adef2c545c3"
16
17 SRC_URI = "https://pypi.python.org/packages/source/C/CherryPy/CherryPy-${PV}.tar.gz"
18 SRC_URI[md5sum] = "c1b1e9577f65f9bb88bfd1b15b93b911"
19 SRC_URI[sha256sum] = "dc5a88562795c2ee462dac5b37aba1cf4f34f3e27281ec11049227039308b691"
20
21 S = "${WORKDIR}/CherryPy-${PV}"
22
23 inherit setuptools
24
25 FILES_${PN} += "\
26     ${datadir}/cherrypy \
27 "