Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-castellan_git.bb
1
2 DESCRIPTION = "Generic Key Manager interface for OpenStack"
3 HOMEPAGE = "https://github.com/openstack/castellan"
4 SECTION = "devel/python"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
7
8 SRCREV = "8e2929b8779eaa03f15a25da5cf64ef8539a026b"
9 SRCNAME = "castellan"
10 PROTOCOL = "https"
11 BRANCH = "stable/stein"
12 S = "${WORKDIR}/git"
13 PV = "0.17.0+git${SRCPV}"
14
15 SRC_URI = "git://opendev.org/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
16
17 inherit setuptools
18
19 DEPENDS += " \
20         python-pip \
21         python-pbr-native \
22         "
23
24 RDEPENDS_${PN} += " \
25         python-pbr \
26         python-babel \
27         python-cryptography \
28         python-barbicanclient \
29         python-oslo.config \
30         python-oslo.context \
31         python-oslo.i18n \
32         python-oslo.log \
33         python-oslo.utils \
34         python-keystoneauth1 \
35         "