Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-backports-init_1.0.bb
1
2 SUMMARY = "Helper package to avoid backports/__init__.py conflicts"
3 DETAIL = "backports packages in python2 suffer from a flaw in the namespace \
4 implementation and can conflict with each other. For OE purposes, at least \
5 fix the conflicting install of .../site-packages/backports/__init__.py"
6 AUTHOR = "Tim Orling <ticotimo@gmail.com>"
7 SECTION = "devel/python"
8
9 LICENSE = "MIT"
10 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
11
12 SRC_URI = "file://backports/__init__.py"
13
14 inherit python-dir
15
16 # provide to avoid warnings
17 do_compile() {
18     :
19 }
20
21 do_install() {
22     install -d ${D}${PYTHON_SITEPACKAGES_DIR}/backports
23     install ${WORKDIR}/backports/__init__.py ${D}${PYTHON_SITEPACKAGES_DIR}/backports/
24 }
25
26 FILES_${PN} = "${PYTHON_SITEPACKAGES_DIR}/backports/__init__.py"