Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-aodhclient_git.bb
1
2 DESCRIPTION = "client library for Aodh built on the Aodh API"
3 HOMEPAGE = "https://launchpad.net/python-aodhclient"
4 SECTION = "devel/python"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
7
8 SRCREV = "a8651ec642058a17cd7a6b3648d8250450a73efb"
9 SRCNAME = "python-aodhclient"
10 BRANCH = "stable/train"
11 PROTOCOL = "https"
12 PV = "1.3.0+git${SRCPV}"
13 S = "${WORKDIR}/git"
14
15 SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
16         
17 inherit setuptools monitor rmargparse
18
19 DEPENDS += " \
20         python-pip \
21         python-pbr-native\
22         "
23
24 # Satisfy setup.py 'setup_requires'
25 DEPENDS += " \
26         python-pbr-native \
27         "
28
29 RDEPENDS_${PN} += " \
30         python-pbr \
31         python-cliff \
32         python-oslo.i18n \
33         python-oslo.serialization \
34         python-oslo.utils \
35         python-keystoneauth1 \
36         python-six \
37         python-osc-lib \
38         python-pyparsing \
39         python-osprofiler \
40         "
41
42
43 do_install_append() {
44         :
45 }
46
47 FILES_${PN} += " \
48         "