Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-adal_1.0.2.bb
1
2 DESCRIPTION = "Microsoft Azure Active Directory Authentication Library (ADAL) for Python"
3 HOMEPAGE = "https://github.com/AzureAD/azure-activedirectory-library-for-python"
4 SECTION = "devel/python"
5 LICENSE = "MIT"
6 LIC_FILES_CHKSUM = "file://setup.py;beginline=2;endline=27;md5=43b81fae9d7baa1f0b1c9774a68ca33a"
7
8
9 inherit pypi setuptools
10
11 PYPI_PACKAGE = "adal"
12
13 SRC_URI[md5sum] = "895791621c696fbbb00dee975260f890" 
14 SRC_URI[sha256sum] = "4c020807b3f3cfd90f59203077dd5e1f59671833f8c3c5028ec029ed5072f9ce"
15
16 RDEPENDS_${PN} += " \
17         ${PYTHON_PN}-requests \
18         ${PYTHON_PN}-dateutil \
19         ${PYTHON_PN}-pyjwt \
20         ${PYTHON_PN}-crypt \
21         ${PYTHON_PN}-datetime \
22         ${PYTHON_PN}-json \
23         ${PYTHON_PN}-logging \
24         ${PYTHON_PN}-netclient \
25         ${PYTHON_PN}-threading \
26         ${PYTHON_PN}-xml \
27         "